Join Us!

CRU Wiebetech USB w...
 
Notifications
Clear all

CRU Wiebetech USB write blocker.  

  RSS
renx215
(@renx215)
New Member

So I have the usb 2.0 write blocker, The one you plug in usb and you plug an evidence usb drive in it. I have windows 10 1703. When I plug the drive in, the green status light goes on, I connect a usb drive, hit remount, but windows does not seem to detect it. If I use the forensic software utility it does not recognize the write blocker. if i stick a drive in, i will get the safely eject drive icon in the tray bar, sometimes followed up with the message that drivers cannot be installed.

I would update the firmware of the write blocker, but again the FSU utility does not detect it. Any ideas? I am assuming since the green light goes on it is working. Have tried on a couple windows PC, and on a linux live cd as well, and all are no go.

Quote
Posted : 07/08/2017 1:09 am
renx215
(@renx215)
New Member

Funny, I have an ultradock 4, I did order the 5.5 but the 4 does not seem to be detected in FSU or the configurator. I have read there were issues with Win 7,

Can anyone confirm these devices work windows 8 and up

ReplyQuote
Posted : 07/08/2017 2:26 am
athulin
(@athulin)
Community Legend

I would update the firmware of the write blocker, but again the FSU utility does not detect it. Any ideas?

No firm ideas – has it ever worked? If not, talk to Wiebetech. You may have a device from a bad batch that got bad firmware installed.

If it has worked, I'd probably fire up WireShark with USBPcap or similar USB sniffer to see a) what happens in the protocol on a system where things do work, and b) what happens on a system where it doesn't. Is the host-to-device commands the same? Is there any point where things break off? Some point where either the commands stop being answered, or where the next command in sequence is not the expected one.

But even then, I'd get in touch with the manufacturer as soon as possible.

ReplyQuote
Posted : 07/08/2017 2:35 am
renx215
(@renx215)
New Member

the last time I really used either device was maybe win xp or 7. I kept them both in good care. it's just funny because both devices are having the same issue. like I said I ordered the new ultradock. but the usb device is basically the same 2.0 one they had for ages.

ReplyQuote
Posted : 07/08/2017 3:06 am
fraudit
(@fraudit)
Member

This might have been already answered but if not, here's the catch. See the CRU's webpage for this device and you will see

Drive Types Supported
- USB Thumb Drives
- USB drives via USB cable (if the device class is USB Mass Storage Device and it does not use proprietary firmware)

I guess your issue lies with the part in bold.

ReplyQuote
Posted : 28/08/2019 4:28 pm
Share: