Join Us!

USB Hard Drive fail...
 
Notifications
Clear all

USB Hard Drive failure  

  RSS
Rubicon812
(@rubicon812)
New Member

I have a Maxtor Personal Storage 3100 external usb hard drive that seems to have died, and I was wondering if there were any tricks someone might suggest to me to recover the data. Being a college kid trying to start my own business, losing half my projects is really painful. )

The drive seems to spin up, and makes weak clicking noises like it's trying to read the disk. When connected to the computer, at first it came up as unrecognised device and told me to 'replace the device'. Now it doesn't even detect that. It also decides randomly to freeze with the activity light on. (This is all without my computer detecting that it exists.)

Any ideas?

Thanks!
Carl

Quote
Posted : 26/09/2005 1:09 pm
itcentral
(@itcentral)
New Member

If its out of warranty, strip the chassis off and see if it's detected via the internal IDE bus.

You can then check the model and try and ebay a replacment for the PCB/controller

ReplyQuote
Posted : 26/09/2005 6:53 pm
Rubicon812
(@rubicon812)
New Member

It's not out of warranty, and all I have at my disposal, really, is a laptop. P

I'm not too worried about whether it's in warranty or not as compared to the data on it. Actually, I have a really old desktop around here somewhere, are my chances good enough that it's worth trying to find all the pieces? That'll probably take awhile )

Carl

PS - I left it plugged in for awhile, and it warmed up and is back to the 'device not recognised' a opposed to no detection at all. Is it possible it was warped due to heat? There isn't very good AC in the room it's in, so it could have gotten rather hot when I was copying a few gigs onto it yesterday. If so, is it worth trying to heat it back up to roughly the same temperature that it was at last time it worked, by leaving it on for awhile?

The drive isn't really designed to be turned off often, and had been on for probably a month. The thing doesn't even have a way to power it off besides pulling the plug.

ReplyQuote
Posted : 27/09/2005 1:11 am
arashiryu
(@arashiryu)
Active Member

I had a similar issue with an Iomega USB drive. After I tried everything in windows enviornment, I used a Symantec Norton Ghost Bootable floppy and was able to ghost it and then extract files I needed via Ghost Explorer. Ghost 2003 came with my Iomega USB drive. Not sure if yours did.

You can also go to bootdisk.com and download a universal bootable floppy with usb drivers and see if you can get to the drive prompt.

Keep us posted on the progress and we can try some other troubleshooting steps.

Please Note Sometimes you can make the problem worse by keep trying to access a physically damaged drive, if it is physically damaged, in your case.

ReplyQuote
Posted : 27/09/2005 1:49 am
echo6
(@echo6)
Member

Are you sure it is the drive that is failing?

I've experienced component failure of the USB to IDE bridge rather than the drive. Take the drive out and test it on another controller.

ReplyQuote
Posted : 09/10/2005 7:59 pm
armresl
(@armresl)
Senior Member

If you pick up the shipping to and from I will recover what I can for you, if anything can be recovered, "on the arm"

ReplyQuote
Posted : 09/10/2005 11:12 pm
Share: