Notifications
Clear all

Mysterious iPhone

4 Posts
3 Users
0 Reactions
741 Views
(@wotsits)
Posts: 253
Reputable Member
Topic starter
 

As everybody knows many cases can run on for many years, so it is not uncommon to have custody of a seized device for a very long time.

Simple hard drives are less of a concern, but when it comes to more complex devices like iPhones I try to periodically check they are still kept in good working order.

I have one iPhone 6s, and according to the record the last time I took it out was two years ago. At the time it was charged up to 100% and then powered off and sealed away.

Recently I took it out again, naturally I expected the charge would have dropped a little even while it was powered off all this time, but I tried to turn it on and it wouldn't. I connected it to power to charge it and for a long time it had no reaction. Eventually the battery picture appeared on the screen with the red warning indicating it was out of charge. I left it to charge for a while and then when it came on again the screen appeared to have a life of its own. Without being touched it was scrolling through the screen and pressing numbers on its own. I didn't want it to alter any of the data on the device by accident so I quickly shut it off.

I've never experienced this before.

First, does an iPhone continue to slowly use the battery even while it is powered off? I'm very sure it was charged to 100% and never turned on all this time. If not does this indicate the battery has degraded in these two years due to lack of use?

 
Posted : 08/05/2019 11:15 am
passcodeunlock
(@passcodeunlock)
Posts: 792
Prominent Member
 

All batteries discharge in time, even if not used.

The misbehavior on the other hand sounds like damaged sensors. It can be caused by corrosion, which can be caused by a bad / leaking battery. I strongly suggest to dismantle and check the device, clean it and replace the battery if needed.

 
Posted : 08/05/2019 10:25 pm
(@wotsits)
Posts: 253
Reputable Member
Topic starter
 

All batteries discharge in time, even if not used.

The misbehavior on the other hand sounds like damaged sensors. It can be caused by corrosion, which can be caused by a bad / leaking battery. I strongly suggest to dismantle and check the device, clean it and replace the battery if needed.

I know, but after only two years? Really?

 
Posted : 09/05/2019 12:55 am
(@josh_hickman1)
Posts: 2
New Member
 

Have you checked the digitizer of the phone? My experience with false inputs is that there is usually damage to the screen and/or digitizer that will cause a phone to act the way you describe. You can pick up a new one online for 12 - 20 bucks, and you can find tutorials online on how to replace it.

 
Posted : 13/05/2019 9:21 pm
Share: